Sniper Elite V2 [PAL- NTSC U]

Sniper Elite V2 [PAL  NTSC U] xgd 2 game pal ntsc u

The sequel to the highly-acclaimed 2005 game Sniper Elite, Sniper Elite V2 continues to offer gamers the most authentic World War II sniping experience by putting them in the middle of war-torn Berlin amidst the frenzied final battle between German and Russian forces.

With an emphasis on learning to handle the anticipation and pressure of the hunt, players are forced to use skill, patience and cunning to achieve their missions as they find themselves facing life-altering choices. The celebrated “bullet cam” from Sniper Elite makes its return and will be more gratifying than ever. Skillful shots are rewarded with a slow-motion sequence of the bullet running its full trajectory from barrel to target as well as featuring graphic detail of the effects of the bullet entering and destroying a target.

ABGX VERIFICATIONSCREENSHOTS GAMEPLAY

Game Info

SS VERSION: Version 2

WAVE: Wave 14 (XGD2)

RELEASE NAME: Sniper Elite V2 XBOX360-COMPLEX

REGION: PAl & NTSC-U

LANGUAGES: English, French, German, Italian & Spanish

RELEASE DATE(S): May 3, 2012


FAQ/Important Notes. Click to Read

Q: On which firmware can i run this?
Ans: This game has a mondatory 14719 dashboard update in it. This also has the new dae.bin in it. But as this is a XGD2 game you can still run it on LT+ 2.0.

Q: Would you recommend updating my dashboard if my console is flashed with LT+ 2.0?
Ans: No, definitly not. If your console has LT+ 2.0 and you update your dashboard to 2.0.14719 your console’s dae.bin will be updated and you wont be able to play most XGD3 games.

Q: What will this new dae.bin do?
Ans: If your console’s dae.bin is updated and your console is flashed to LT+ 2.0 (apart from hitachi 32 to 59 hitachi and samsung), you will not be able to play any XGD3 game.

Q: Is this a silent update or will i be asked to update manually?

Ans: This is not a silent dashboard update. The game will prompt you to update your dashboard.

Q: Is this dashboard safe for consoles flashed with LT+ 3.0?

Ans: Yes. Consoles flashed with LT+ 3.0 will work just fine after this update.

Q: Should i run this game through abgx?

Ans: Yes. You should run every xbox 360 game through abgx360 so that you can check whether the iso is corrupted or not. Make sure you use the latest version of abgx360.

Q: Why does abgx360 1.0.6 say that verification of this game failed?

Ans: Dont worry about that. You are getting that message because this game hasn’t been added to abgx’s database yet. As soon as it is added your entire log will be green.
Please note that if a game’s SS & DMI files are valid, it has been patched with the topology data and if there is no CrC corruption then that ISO is safe to play.

Q: What software should i use to burn this game?

Ans: IMGburn and CloneCD both work with XGD3 games, i personally recommend ImgBurn.

Q: I have a pre 78-79 hitachi/ Samsung with LT+ 2.0b will i be able to play this game?

Ans: Yes, as your console is immune to every ap2.5 check you can play this game online and offline safely. Just make sure that you burn your games properly.


Q: Where are the links?
Ans: As links are deleted very quickly nowadays, i have pasted them in a pastebin. To get the download links, click on the button of the host you want to download from. A new window will open and you will get your links


Click the button below to download the .DLC file containing hulkshare links. You can only use jdownloader, (or similar programs) to open this .dlc file.



Click the button below to download the .DLC file containing gamefront links. You can only use jdownloader, (or similar programs) to open this .dlc file.


SHARE THIS POST

  • Facebook
  • Twitter
  • Myspace
  • Google Buzz
  • Reddit
  • Stumnleupon
  • Delicious
  • Digg
Author: CS View all posts by